追記
- 2025年1月16日(木)13時36分:「影響範囲」「現象」「原因」を加筆、「対応経過」「再発防止策」を追加しました。
- 2025年1月15日(水) 15時37分:「影響範囲」「原因」「対処」「お客様へのお願い」を追加しました。
- 2025年1月15日(水) 15時08分:「障害発生時間」「障害復旧時間」「対処」を追加しました。
お客様各位
日頃はビデオグをご利用いただきまして誠にありがとうございます。
本日2025年1月15日(水)の14時05分頃より、ビデオグサービスが利用できない状況が発生しておりました。現在復旧し、弊社サービスが正常にご利用いただける状態に回復いたしましたのでご報告いたします。
■障害発生時間
- 2025年1月15日(水)14時05分
■障害復旧時間
- 2025年1月15日(水)14時55分
■影響範囲
- 本障害による影響を受けたユーザー
- 障害発生時間内にビデオグサービスのWebページへのアクセスを試みたすべてのユーザー
- 影響を受けなかったユーザー
- 障害発生前にすでにページを開いており、継続して動画を視聴していたユーザー
- 動画リストAPIを介して自社アプリ等で動画を再生していたユーザー
- 本障害はWebページへのアクセスに限定された事象であり、動画配信システムのコアサービスには影響ありませんでした。そのため、既存セッションや外部APIを利用した動画再生は正常に継続できる状態でした。
■現象
- 新規にビデオグサービスのページが開けない
■原因
- 事象の発端: 特定ユーザー向けのライブ配信録画管理機能における不具合修正作業の実施
- 直接的な原因: 改修用ソースコードに、想定外の全体システムへの影響を及ぼす処理が含まれていたこと
■対処
- 不具合を起こしたプログラムコードの修正
■対応経過
- 1/15 14:00:特定ユーザーのための録画機能の不具合の修正作業を実施
- 1/15 14:15:www.videog.jpで500エラーが発生していることを検知
- 1/15 14:50:原因を特定
- 1/15 14:55:対策を実施
- 1/15 14:56:社内テストにて障害の解消を確認
- 1/15 15:00以降:障害報告を順次開始
■再発防止策
- コードレビュープロセスの徹底
- レビュアーによるクロスチェック
- 静的解析ツールの導入
- 変更管理プロセスの厳格化
- 変更内容の事前レビュー必須化
■お客様へのお願い
- お客様のアクションはございません
重ねましてお客様には大変ご迷惑をお掛けいたしましたことをお詫び申し上げます。 今後、同様の事象が生じないよう、より高い安全性・信頼性を目指し、システムの構築・運用を行ってまいります。
お客様におかれましては引き続き弊社をご愛顧賜りますよう何卒よろしくお願い申し上げます。